composer.json for bjy-authorize,zfcUser和zfc-user-doctrine-orm in ZF2

composer.json for bjy-authorize, zfcUser and zfc-user-doctrine-orm in ZF2


composer.json for bjy-authorize,zfcUser和zfc-user-doctrine-orm in ZF2 已获得2个解决方法 2020-08-18 18:08:08 zend-framework2

我正在尝试使用composer在ZF2中使用bjy-authorize,zfcUser和zfc-user-doctrine-orm.但是我总是得到一个错误,当我调用composer.phar更新.

composer.json如下所示:

    {
"name": "zendframework/skeleton-application",
"description": "Skeleton Application for ZF2",
"license": "BSD-3-Clause",
"keywords": [
    "framework",
    "zf2"
],
"homepage": "http://framework.zend.com/",
"minimum-stability": "alpha",
"require": {
    "php": ">=5.3.3",
    "zendframework/zendframework": "2.*",
    "doctrine/doctrine-orm-module": "dev-master",
    "bjyoungblood/bjy-authorize": "dev-master",
    "zf-commons/zfc-base": "dev-master",
    "zf-commons/zfc-user": "dev-master",
    "zf-commons/zfc-user-doctrine-orm": "dev-master"
}
}

我在没有最后3行 (以 “zf-commons开头) 的情况下尝试了该操作,但没有错误,但是未安装zfc-user-doctrine模块.

    Your requirements could not be resolved to an installable set of packages.
    Problem 1
- Conclusion: don't install zf-commons/zfc-base 0.0.1
- Conclusion: remove bjyoungblood/bjy-authorize dev-master|install zf-commons/zfc-base 0.0.1
- Conclusion: don't install bjyoungblood/bjy-authorize dev-master|remove zf-commons/zfc-base dev-master|install zf-commons/zfc-base 0.0.1
- Installation request for bjyoungblood/bjy-authorize dev-master -> satisfiable by bjyoungblood/bjy-authorize dev-master.
- bjyoungblood/bjy-authorize dev-master requires zf-commons/zfc-user dev-master -> satisfiable by zf-commons/zfc-user dev-master, zf-commons/zfc-user dev-master.
- zf-commons/zfc-user dev-master requires zf-commons/zfc-base 0.* -> satisfiable by zf-commons/zfc-base 0.0.0, zf-commons/zfc-base 0.0.1, zf-commons/zfc-base 0.1.0.
- zf-commons/zfc-user dev-master requires zf-commons/zfc-base 0.* -> satisfiable by zf-commons/zfc-base 0.0.0, zf-commons/zfc-base 0.0.1, zf-commons/zfc-base 0.1.0.
- Can only install one of: zf-commons/zfc-base dev-master, zf-commons/zfc-base 0.0.0.
- Can only install one of: zf-commons/zfc-base dev-master, zf-commons/zfc-base 0.1.0.
- Installation request for zf-commons/zfc-base dev-master -> satisfiable by zf-commons/zfc-base dev-master

我必须在composer.json文件中更改什么?

最好,冰人


composer.json for bjy-authorize,zfcUser和zfc-user-doctrine-orm in ZF2 方法1

您可以如下修复您的 composer.json :

{
    "require": {
        "php": ">=5.3.3",
        "zendframework/zendframework": "2.*",
        "doctrine/doctrine-orm-module": "~0.7",
        "bjyoungblood/bjy-authorize": "~1.1",
        "zf-commons/zfc-user": "~0.1",
        "zf-commons/zfc-user-doctrine-orm": "~0.1"
    }
}

如果您不知道自己在做什么,请避免使用 dev-master .


composer.json for bjy-authorize,zfcUser和zfc-user-doctrine-orm in ZF2 方法2

问题是Zf-Commons已开始标记其发行版.如果我是你,我会删除zfc-user,zfc-base和doctrine-orm-module.

将bjy-authorize的版本从dev-master更改为1.*,将zfc-user-doctrine-orm更改为0.*.然后,Composer应该从那里处理依赖关系.


.htaccess .net .net-core 2d 3d 3d-printing ab-initio abp abstract-syntax-tree actions-on-google actionscript-3 active-directory activemq activemq-artemis acumatica adobe-xd aframe ag-grid agora.io air airflow ajax akka alert alexa algorithm alignment allure amadeus amazon-cloudformation